正在加载中...

关闭
请选择需要拨打的号码
关闭
请根据问题类型选择QQ咨询

在阿里云虚拟主机安装了phpmyadmin为什么打不开syntax error unexpected T string

在阿里云虚拟主机安装了phpmyadmin为什么打不开syntax error unexpected T string

用户反映在万维景盛租用了阿里云虚拟主机,上传phpmyadmin后打不开,报错内容为syntax error,  unexpected T_string expecting T_CONSTANT_ENCAPSED_STRING or '(' in phpmyadmin/index.php on line 8万维景盛工程师为您分享解决方法。

phpmyadmin打不开.png

经了解,用户下载了最新开发版phpmyadmin4.7.0 rc1,这是一个未正式发行的实验版本,问题在所难免,同时,phpmyadmin不同的版本只能对应相应版本的php环境使用,如果你在虚拟主机控制面板选择了错误的php版本,那么phpmyadmin运行也会出错。

下面是不同的phpmyadmin版本对应运行的php环境版本对照表,供大家参考:

phpMyAdmin 4.6.6 下载地址:phpMyAdmin-4.6.6-all-languages.zip

Released 2017-01-23发行Current version compatible with 最新版兼容PHP 5.5 to 7.1 and及数据库版本 MySQL 5.5 and newer.

phpMyAdmin 4.4.15.10下载地址:phpMyAdmin-4.4.15.10-all-languages.zip

Released 2017-01-23发行Older version compatible with这是一个旧版本,兼容PHP 5.3.7 to 7.0 and MySQL 5.5. This version is no longer supported for security fixes. Users are urged to upgrade.这个版本已经不再进行安全补丁更新,建议使用最新版本。

phpMyAdmin 4.0.10.19下载地址:phpMyAdmin-4.0.10.19-all-languages.zip

Released 2017-01-23发行 Older version compatible with这是一个早期版本,兼容PHP 5.2 and MySQL 5. Supported for security fixes only, until April 1, 2017.这个版本安全补丁更新至2017年4月1日,以后将不再更新,建议使用最新版本。

万维景盛提供可以远程连接的独立数据库租用、数据导入、数据导出、数据备份还原、mysql-mssql-excel-csv等转换数据格式等服务,欢迎垂询客服!


返回上一页